La nueva versión PHPUnit pedirá, como mínimo, PHP7

La nueva versión PHPUnit pedirá, como mínimo, PHP7

Acaba de salir la nueva versión de PHPUnit, versión 6, con una novedad muy importante. Ahora necesitas, como mínimo la versión 7 de PHP.

No debería ser una noticia sorprendente teniendo en cuenta que la versión 5.6 de PHP ya no tendrá soporte oficial (tan sólo corrección de errores hasta Diciembre de 2018).

Cada vez son más los proyectos que están retirando el soporte para versiones de PHP 5.x pero se siguen viendo muchos servidores que funcionan incluso con la 5.2. Ya va siendo hora de actualizar.

¿Qué es PHPUnit?

PHPUnit es una herramienta para desarrolladores que permite hacer pruebas automatizadas en PHP.

¿Y esto qué significa? Resumiendo mucho: Usar pruebas automatizadas nos permite comprobar si todos los aspectos de nuestra aplicación funcionan de la manera esperada y sin fallos. Podemos hacer cambios y comprobar si nos hemos cargado algo en segundos ¡Un chollo!

Novedades en esta nueva versión

Esta versión trae algunos métodos nuevos, opciones para la línea de comando y corrección de fallos (de hecho han publicado tres versiones desde el día 3 de Febrero con correcciones).

  • Añadidos lo métodos getExpectedExceptionCode() y getExpectedExceptionMessage().
  • Nuevo método PHPUnit\Framework\TestCase::createTestProxy() para probar proxies.
  • Nueva opción para –dont-report-useless-tests.
  • Nueva opción –globals-backup.

Puedes consultar la lista completa de cambios de PHPUnit 6.0 en su GitHub.

¿Qué pasa con las versiones anteriores?

La versión 5.7 de PHPUnit seguirá teniendo soporte oficial hasta Febrero de 2018 así que se puede seguir usando.

La versión 4.8 se queda ya sin soporte así que ya es una versión obsoleta. No se van a corregir ni los errores.

Más información, en inglés, aquí.

Deja un comentario